Disturbance with online payments and payment imports

Incident Report for Maxxton

Resolved

The issue affecting online payments and payment imports has been resolved. All systems are now operating normally.
Posted Jul 16, 2025 - 09:59 CEST

Investigating

We're currently experiencing issues with payments.
The cause has been found and the team is working on a solution.
Posted Jul 16, 2025 - 09:37 CEST
This incident affected: Maxxton Software and Integrations.