Database outage

Incident Report for Maxxton

Resolved

We are closing this incident now after thorough monitoring the platform. All is healthy and stable currently. Our work continues with a Postmortem and further mitigation actions for the future.
Our sincere apologies for the inconvenience.
Posted Jul 16, 2026 - 10:07 CEST

Monitoring

All environments are back online. We are still doing an overall control check and doing preventive restarts, though this should not impact your work any longer.
Posted Jul 16, 2026 - 08:19 CEST

Update

In the meantime, Google restored the processes in the Netherlands. Since this is our preferred and most performant option, we chose to go back to this option. Currently, a part of the environments is back online, we're working on the remaining. Feel free to keep trying, it won't harm.
Posted Jul 16, 2026 - 08:03 CEST

Update

Failover to our backup datacenter is in progress. Two of the three core components have now successfully switched over. The remaining component requires careful synchronization and validation to ensure data integrity, so the recovery is taking longer than we would like.

Our team is fully focused on completing the failover and restoring service, with the goal of recovering before the start of the European business morning. We appreciate your patience and will provide another update as soon as we have meaningful progress to share.
Posted Jul 16, 2026 - 07:08 CEST

Update

Following the power and cooling incident at our primary datacenter, we are initiating a failover to our backup datacenter. Our teams are actively executing the recovery plan to restore database availability and application services. We will continue to provide updates as the failover progresses.
Posted Jul 16, 2026 - 05:32 CEST

Identified

We have identified the root cause of the outage as an infrastructure issue involving power and cooling at the datacenter hosting our database servers. This has affected application availability and performance. We are working closely with our infrastructure provider to restore normal service.
Posted Jul 16, 2026 - 04:23 CEST

Investigating

We are investigating an issue affecting our database infrastructure.
Posted Jul 16, 2026 - 04:00 CEST
This incident affected: Maxxton Software, API, Web Manager, Integrations, and Operations App.