Google Cloud Storage issues

Incident Report for Maxxton

Resolved

We are closing this incident and will follow up with Google on a root cause analysis. The Google Cloud regions we use are recovered. Apologies for the inconvenience caused.

Reference to the Google Cloud incident: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 21:37 CEST

Monitoring

Google is now reporting the issues as well. But we also see systems recover over the last minutes. We filed a p1 support case to get a better understanding too. For now, Maxxton Software is fully operational again.
Posted Jun 12, 2025 - 21:00 CEST

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 20:39 CEST

Update

It's impacting Maxxton Software now as well. For example, authenticating with a new session is failing. Google status pages are green but more people are reporting issues over the internet. We are trying to understand what is going on.
Posted Jun 12, 2025 - 20:39 CEST

Investigating

We are currently experiencing errors in the background that Maxxton Software is not able to communicate with the storage in Google Cloud. We are investigating the impact and checking with Google what is going on.
Posted Jun 12, 2025 - 20:24 CEST
This incident affected: Maxxton Software, API, Web Manager, and Integrations.