Database performance for one of the databases

Incident Report for Maxxton

Resolved

We will close the incident again. All is calm after mitigating actions on the database instance. This is not a day to repeat.
Posted Jul 16, 2026 - 20:00 CEST

Monitoring

The system is calm again, we're monitoring and checking all metrics.
Posted Jul 16, 2026 - 19:24 CEST

Investigating

We are currently facing performance issues in one of the production databases. This only impacts a part of our client base and seems to be something hanging since the outage of this morning. Our engineers are looking into it with high priority.
Posted Jul 16, 2026 - 18:55 CEST
This incident affected: Maxxton Software, API, Web Manager, Integrations, and Operations App.