Issues with payment registrations

Incident Report for Maxxton

Resolved

We will close the incident now, no more issues have been noticed. We found the root cause of the errors and are investigating further how this happened and how we can prevent it.
Posted Jul 15, 2026 - 12:09 CEST

Monitoring

Currently, the situation is back to normal, however we haven't found the actual cause yet. We continue our investigation.
Posted Jul 15, 2026 - 09:18 CEST

Investigating

We are investigating error logs in the platform, concentrated around (cash) payments. We tried to mitigate the impact till now without success. More updates as soon as possible.
Posted Jul 15, 2026 - 08:44 CEST
This incident affected: Maxxton Software and API.